Maelstrom Server Argument Buffer Overflow Vulnerability

Solution:
Andrew Church has supplied an unsupported unofficial patch to address this issue for maelstrom version 3.0.6.

Gentoo has released an advisory for this issue. Gentoo can apply the app-games/maelstrom upgrade to maelstrom-3.0.6 with the following commands:

emerge sync
emerge maelstrom
emerge clean


Sam Lantinga Maelstrom 3.0.6


 

Privacy Statement
Copyright 2010, SecurityFocus