Node.js CVE-2016-2086 HTTP Request Smuggling Vulnerability

Bugtraq ID: 83282
Class: Input Validation Error
CVE: CVE-2016-2086
Remote: Yes
Local: No
Published: Feb 09 2016 12:00AM
Updated: Nov 24 2016 09:04AM
Credit: RĂ©gis Leroy.
Vulnerable: Joyent Node.js 5.0
Joyent Node.js 0.12
Joyent Node.js 0.10
Joyent Node.js 4.0
IBM SDK for Node.js 1.2.0.8
IBM SDK for Node.js 1.1.0.18
IBM Rational Application Developer for WebSphere Software 9.5
IBM Rational Application Developer for WebSphere Software 9.1
IBM Business Process Manager Standard 8.5.6
IBM Business Process Manager Standard 8.5.5
IBM Business Process Manager Standard 8.5.7
IBM Business Process Manager Express 8.5.6
IBM Business Process Manager Express 8.5.5
IBM Business Process Manager Express 8.5.7
Apple Xcode 7.3.1
Apple Xcode 6.0.1
Apple Xcode 2.4.1
Apple Xcode 8
Apple Xcode 7.3
Apple Xcode 7.2
Apple Xcode 7.1
Apple Xcode 7.0
Apple Xcode 6.3
Apple Xcode 6.2
Apple Xcode 6.0
Apple Xcode 5.0
Apple Xcode 4.4
Apple Xcode 4.3.3
Apple Xcode 4.3.2
Apple Xcode 4.3.1
Apple Xcode 4.3
Apple Xcode 4.2.1
Apple Xcode 4.2
Apple Xcode 4.1.1
Apple Xcode 4.0.2
Apple Xcode 4.0.1
Apple Xcode 4.0
Apple Xcode 3.2.5
Apple Xcode 3.2.4
Apple Xcode 3.2.3
Apple Xcode 3.2.2
Apple Xcode 3.2.1
Apple Xcode 3.1.4
Apple Xcode 3.1.3
Apple Xcode 3.1.2
Apple Xcode 3.1.1
Apple Xcode 3.1
Apple Xcode 3.0
Apple Xcode 2.3
Apple Xcode 2.2
Apple Xcode 2.1
Apple Xcode 2.0
Apple Xcode 1.5
Not Vulnerable: Joyent Node.js 5.6
Joyent Node.js 4.3 LTS
Joyent Node.js 0.10.42
Joyent Node.js 0.12.10(LTS)
IBM SDK for Node.js 1.2.0.9
IBM SDK for Node.js 1.1.0.19
Apple Xcode 8.1


 

Privacy Statement
Copyright 2010, SecurityFocus