Multiple Vendor LibX11/X11 Toolkit/Athena Widget Library Buffer Overflows Vulnerability

SCO Openserver and SGI IRIX (6.2 confirmed, possibly others) are vulnerable to several buffer overflows in various shared libraries related to the X window system. This means that all programs which link to these libraries could be vulnerable to exploitation through buggy library calls. The vulnerable libraries are:

LibX11
LibXt
LibXaw
LibXmu

This vulnerability may be similar to serious X library overflows, in our database as Bugtraq ID 237 (published in August, 1997) and the Sun X problems archived in our database as Bugtraq ID 238 (published in May, 1999).


 

Privacy Statement
Copyright 2010, SecurityFocus