Monit Overly Long HTTP Request Buffer Overrun Vulnerability

Solution:
The vendor has release Monit 4.1.1 to address this issue in affected versions. Users are advised to upgrade to the latest version as soon as possible.

Gentoo has released an advisory GLSA 200403-14 to address this and another issue in Monit. Please see the referenced advisory for more information. Gentoo users may carry out the following commands to upgrade to Monit version 4.2:

# emerge sync
# emerge -pv ">=app-admin/monit-4.2"
# emerge ">=app-admin/monit-4.2"


TildeSlash Monit 1.4

TildeSlash Monit 1.4.1

TildeSlash Monit 2.0

TildeSlash Monit 2.1

TildeSlash Monit 2.1.1

TildeSlash Monit 2.2

TildeSlash Monit 2.2.1

TildeSlash Monit 2.3

TildeSlash Monit 2.4

TildeSlash Monit 2.4.1

TildeSlash Monit 2.4.2

TildeSlash Monit 2.4.3

TildeSlash Monit 3.0

TildeSlash Monit 3.1

TildeSlash Monit 3.2

TildeSlash Monit 4.0

TildeSlash Monit 4.1


 

Privacy Statement
Copyright 2010, SecurityFocus