Moodle CVE-2017-2644 HTML Injection Vulnerability

Moodle is prone to an HTML-injection vulnerability because it fails to sanitize user-supplied input.

Successful exploits will allow attacker-supplied HTML and script code to run in the context of the affected site, potentially allowing the attacker to steal cookie-based authentication credentials or control how the site is rendered to the user. Other attacks are also possible.

Moodle 3.2 through 3.2.1 and 3.1 through 3.1.4 are vulnerable.


 

Privacy Statement
Copyright 2010, SecurityFocus